Products listed are not on Facebook Catalog.
May 4, 2023
Cause
Publishing on Facebook Catalog products may not be transferred even if the publication was completed with no error. In this case, you may have issues with:
- Non-compliance of product content with Facebook rules.
- Incompleted permissions granted to Nembol.
Solution
Check and fix products description
Check your product description and make sure you’re not using invalid characters or emoji. Make sure you don’t have the product descriptions fully in CAPS LOCK.
Review permissions granted to Nembol
- Open your Products tab
- Delist products that didn’t go through Meta.
- Open Channels tab
- Log out from Meta Commerce by clicking on the red “x” button.
- Log into your Facebook personal profile.
- Click on the top right of the page to open the drop-down menu.
- Click on “Settings & Privacy” – See the screenshot on your left.
- Open “Security and login” – See the screenshot on your right.


Click on the “Business integrations” settings – See the screenshot below.

Now remove Nembol integration – See the screenshot below.

Once done, go back to the Nembol, and:
- Go to Channels tab
- Log into Meta Commerce.
- Grant full permission.
- Click on “Continue as…”

As soon as you’ve finished granting permissions, you’ll be redirected to Nembol, and the Meta settings will open.
- Choose the catalog you want to list on. If you’re not the catalog owner, make sure you have full editing permissions as a user.
- Save changes.
- Retry the products publication.
