Updated on July 24, 2024
Full error name: “Facebook Shops wrong Catalog”
Cause
You have probably added the wrong Business Page at the beginning of the setup process.
Solution
Connect the right Catalog:
- Remove your currently connected Page.
- Connect the correct one.
Here you can read a detailed step-by-step guide with pictures ->
In short. First thing to do is to clear the connection with Facebook.
- Disconnect Meta Commerce from Nembol.
- Go to your Facebook Personal Profile.
- Go to your Settings and Privacy > Settings.
- Scroll down the left menu and select “Business Integrations”
- Remove Nembol.
![settings facebook](https://i0.wp.com/help.nembol.com/wp-content/uploads/2023/05/Immagine-2023-05-02-144448-1h.png?fit=496%2C322&ssl=1)
Once done, let’s add the correct Catalog. Go back to myapp.nembol.com and:
- Go to your Channels Tab.
- Click on the “Connect channels +” button.
- Choose Meta Commerce.
- You will be taken to Facebook. Click on “Continue as + your Name”.
- Click on “View Access”.
- By ticking them on, associate only the Business Page for which you want to use Nembol with.
- Click on continue.
- Confirm, and all is done.
![grant permissions facebook](https://i0.wp.com/help.nembol.com/wp-content/uploads/2023/05/image.png?fit=733%2C688&ssl=1)