I’m not receiving any orders from WooCommerce

Updated on Aug 5, 2024

You are not receiving any orders from WooCommerce?

Cause

The title says it all: you don’t have any orders from WooCommerce in your Nembol account. Therefore, the inventory is not updating.

Solution

Turn ON the webhooks in the WooCommerce account.

Please check that your webhooks are active – See screenshot below. This will allow WooCommerce to send orders to your Nembol account.

WooCommerce_Settings_2024

Order statuses

It is important to note that WooCommerce has several orders statuses, which can be read directly from WooCommerce oder status support page

Only orders in statuses:

  • Processing
  • Completed

Are collected from Nembol and concur at updating your stock count in Nembol, and through Nembol in the connected channels.

Orders in other statuses are ignored by Nembol. Therefore you will not see all of your WooCommerce orders inside your Nembol account, but only the orders that are in either of the two WooCommerce statuses a) Processing, b) Completed.

Timing -- or when will your stock update

As a regular operation, Nembol will receive your WooCommerce orders a few minutes after they enter either the ‘Processing’ or ‘Completed’ status.

Immediately after, as soon as orders will be in Nembol, Nembol will update your stock count for the products ordered.

There are cases when server connection may be faulty. This may happen, although seldom, for a number of reasons. After all, we are asking servers very far away one another to talk together seamlessly, and this happens over the Internet connections provided by several third party companies.

To make sure no fault will break your stock count, Nembol has a back-up order-collection routine:

Every ten minutes, Nembol monitors your WooCommerce account, and collects any order that is not yet in Nembol. This happens up to 24 hours in the past.

This additional feature by Nembol is very important because:

  • It ensures that your stock count in Nembol is as correct as possible
  • It enables you to fix your stock count, also if for some reasons you temporarily disconnect your WooCommerce account from Nembol. As long as the disconnection is shorter than 24 hours.
Therefore, if you do not see some of your WooCommerce orders in your Nembol account, they may still appear up to 24 hours after they entered the correct WooCommerce status.