Updated on May 30, 2024
Full error description: Products listed are not on Facebook Catalog.
Cause
Publishing on Facebook Catalog products may not be transferred even if the publication was completed with no error. In this case, you may have issues with:
- Non-compliance of product content with Facebook rules.
- Uncompleted permissions granted to Nembol.
Solution
1. Check and fix products description
Check your product description and make sure you’re not using invalid characters or emoji.
Make sure you don’t have the product descriptions fully in CAPS LOCK.
2. Review permissions granted to Nembol
- Open your Products tab.
- Delist products that didn’t go through Meta.
- Open Channels tab.
- Log out from Meta Commerce.
- Log into your Facebook personal profile.
- Click on the top right of the page to open the drop-down menu.
- Click on “Settings & Privacy” – See the screenshot on your left.
- Open “Security and login” – See the screenshot on your right.
Screenshot 1: Click on Setting & Privacy section
Screenshot 2: Click on Security and login section
- Click on the “Business integrations” settings – See the screenshot below.
Screenshot 3: Click on Business Integrations section
- Now remove Nembol integration – See the screenshot below.
Screenshot 4: Remove here Nembol integration
- Once done, go back to the Nembol, and:
- Go to Channels tab.
- Log into Meta Commerce.
- Grant full permission.
- Click on “Continue as…”.
Screenshot 5: Log into Meta Commerce
As soon as you’ve finished granting permissions, you’ll be redirected to Nembol, and the Meta settings will open.
- Choose the catalog you want to list on. If you’re not the catalog owner, make sure you have full editing permissions as a user.
- Retry the products’ publication.