Updated on May 31, 2024
Full error name: “Sorry, this item is unavailable“
Cause
There are a couple of reasons why this error may be returned from Etsy:
- Your item is listed on Etsy, but it’s in the draft folder.
- You renewed your products directly in Etsy.
Solution
Delist and relist your items as "Active" instead of "Draft"
As default, Nembol lists the items on Etsy as Drafts, so that you don’t have to pay straight away for listing active products.
You can publish your items as active. Do the following:
- Open your Products tab.
- Bulk select and delist those products from Etsy.
- Access your Channels tab.
- Open Etsy Publish settings.
- In “Listing status” select “Active”.
- Go back to your Products tab.
- Select your products, and list them back to Etsy.
- Starting from now, all the items you list will be published as “Active”.
Delete and reimport your items
Let’s imagine you imported your Etsy products into Nembol. Time passed, and they got expired on Etsy. You reactivated and renewed items directly in Etsy. Once renewed, each product gets a new Product ID. Therefore, the connection with Nembol breaks, and Nembol can’t locate those products anymore.
To fix this:
- Open your Products tab.
- Bulk select and delist those products from channels where they were listed.
- Bulk select and delete those products from Nembol.
- Relist (renew) them directly in your Etsy backend (if haven’t done already)
- Re-import them back to Nembol to be able to edit, re-list and manage them across other connected channels.